OHDSI Home | Forums | Wiki | Github

There is a problem in running Achilles

Hello everyone, I am currently installing OHDSI. There is a problem that I cannot solve in the process of running Achilles. I have tried many methods. For example, deleting all the CDM data will still cause the same error. The specific error is shown in the figure below. Can you give me some suggestions to solve this problem?

achillesError_2004.txt (85.6 KB)

errorReportSql.txt (422 Bytes)
Here is my initialization code:

Could you check whether your person table contains any records? An empty person table would explain the error message (dividing by a count of 0).

1 Like

Yes,my person table is empty.
This is my first time running Achilles. The first step is to run OMOPCDM_ postgresql_ 5.3_ The ddl. sql file creates all the tables. Then I downloaded the required vocabulary from Athena. In this step, I did not do anything, but chose the official default option to download. The downloaded vocabulary is shown below:

Decompress the downloaded compressed package to obtain the following files:

After getting these files, I use the official “OMOP CDM vocabulary load - PostgreSQL. sql” file to import the data.

After this step, I continue to execute the file “OMOPCDM_postgresql_5.3_index. sql” to create indexes. After that, I ran Achilles according to the official instructions and got this error. After I have completed these steps, my person table should not use data, because the data in Athena download is not used to import the person table. So did I miss some data?I just want to execute Achilles correctly first. So where can I get my initial person data?

You first need to populate your OMOP CDM tables with your data before running Achilles. The steps should be:

  2. Load OMOP Vocabularies
  3. Run OMOP CDM Constraints and Indexes
  4. Run ETL from your source data to OMOP
  5. Run data quality/validation tools (DataQualityDashboard, Achilles)

Which instructions were you following? We might need to update those.

1 Like

And if you need some sample data to load into OMOP, consider generating synthetic data with Synthea and using this ETL (which also has some convenience functions for creating OMOP tables and loading the vocabulary): https://github.com/OHDSI/ETL-Synthea

After seeing your reply, I think I have only done the third step before. It may be the lack of the key fourth step that led to this error. I want to ask, if I ETL the words downloaded from Athena, will my Person have data instead of being empty? In addition, I also want to ask how to run ETL for these data.
I can’t find the relevant tutorial. Thank you very much for your answer.

In addition, I want to ask a question, is the data downloaded from Athena compatible with CDM? If not, should they be standardized using ETL? How to use ETL tools to standardize these data?

Have you inspected the data from Athena? These are the contents for the OMOP vocabulary tables. The other OMOP tables still need to be populated from a different source (see my message before).

I’m getting this error:

| 50%2023-03-13 21:17:10 > Merging scratch Achilles tables [ERROR] (Error in .createErrorReport():

! Error executing SQL:
com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name ‘#s_tmpach_dist_716’.
An error report has been created at /Users/sudoshi/OMOP/errorReportSql.txt
2023-03-13 21:17:10 Done. Achilles results can now be found in schema RESULTS
Connecting using SQL Server driver
|================================================================================================================= | 62%Error in .createErrorReport():
! Error executing SQL:
com.microsoft.sqlserver.jdbc.SQLServerException: Cannot find the object “RESULTS.achilles_results_dist” because it does not exist or you do not have permissions.
An error report has been created at /Users/sudoshi/OMOP/errorReportSql.txt
Run rlang::last_error() to see where the error occurred.

This is the first time I have encountered this error. Previously run on a populated db completed without error.


errorReportSql.txt (571 Bytes)

I expect that execution of analysis 716 has failed (this might have happened some time before this error). Please check the full Achilles log for other errors.

Analysis 1203 and 1900 are also affected. You are correct.