OHDSI Home | Forums | Wiki | Github

Problems about setting up achilles

Hi,all
If anyone could help me,when I use the code

exportToJson(connectionDetails, cdmDatabaseSchema = "public", resultsDatabaseSchema = "ohdsi", outputPath = "G:/apache-tomcat-ohdsi/webapps/AchillesWeb-master/data", cdmVersion = "5", vocabDatabaseSchema = "public")

then shows

Connecting using PostgreSQL driver
Generating condition treemap
|=======================================================================| 100%
Generating condition reports
|=======================================================================| 100%
Generating condition era treemap
|=======================================================================| 100%
Generating condition era reports
|=======================================================================| 100%
Generating data density reports
|=======================================================================| 100%
Generating death reports
|=======================================================================| 100%
Generating drug era treemap
|
0%

Seems correct,but it has kept 0% for 2 hours already.I don’t know how to deal with it.My computer seems to be despair and unwilling to work.Should I still wait or if anyone has solutions to make it correct?

Any help would be appreciated.
Sincerely.
-Zhu

you can turn off inidivual .json exports. Look at R function help text. Just skip the long running sub component.

Sorry,I am a fresh man in R, although have read your suggestion,I still don’t know how to deal,but I will try my best to make sense of your suggestion. Thank you for your reply.
Sincerely.
-Zhu

Same. No idea how to bypass drug era. Seems like there are quite some people who had problems with drug era but that was never fixable. And there werent apparent ways to get around running drug era.

The code obviously says it reads system.file("csv", "export", "all_reports.csv", package = "Achilles"), somewhere but I never know where it is after searching.

okay the way to get around it is to copy the whole code from

rename the exportToJson to something like exportToJsonExtra and then comment out the Drug Treemaps section. (Please do not rename it to exportToJson2, somehow R refuses to run that and I totally do not know why. R is the best language!) Then call the function.

Now god knows what is stuck next

@lychenus13 Good to hear that you solved the problem.
For your information and further reference: exportToJson also has an argument reports, where you can specify which reports you want to output. There, you can list all reports except the Drug/DrugEra ones. This might do the same as deleting lines from the code.
image

I guess the way to add that argument with report=c("DRUG", "A", "B", "C",....) this is a vector in R.

But this is only a compromise, not quite a solution. I think there are quite some people want to know why drug_era and drug_exposure analysis do not work for them!

Can you please assist me with the next quetion?

Thanks

t