OHDSI Home | Forums | Wiki | Github

ETL-CDMBuilder Exception found

(belay birlie) #1

When I launch org.ohdsi.cdm.presentation.buildingmanager, it returns the following Error message. Any help?

(Anton) #2


You need to check that Builder database exists and you have correct connection string in org.ohdsi.cdm.presentation.buildingmanager2.exe.Config file.

(belay birlie) #3

Thank you @bradanton. I have created the Builder DB and now I’m running the builder. finger crossed


(belay birlie) #4

Hi @bradanton,

I am really sorry for bothering you a lot. For testing purpose, I am only working on 10 persons data. After 2h the building progress is still in stage 1 - CDM data base creation step, without returning error message. Is that a sign of some thing not working? I am using the CPRD data as it is. Is there any thing I need to do beforehand (eg. changing column names etc) ?

Kind regards

(Anton) #5

Hi Belay,

Feel free to ask. This step should take seconds, it just create database and tables.
Probably you don’t have rights for creating db or etc. and have a long timeout value.
You need to check that you have rights for creation db and tables and restart the cdm builder.


(belay birlie) #6

Thank you Anton!
I think I have the right for creating the db’s (eg. the OHDSI_builder tables are now part of my database after doing what you suggested me earlier which seems I can create db) but I will check with the IT team who created the VM if that is not the case. Is it possible to change timeout value?


(Anton) #7

hmm… seems currently it is hard coded

you can manually create cdm database and tables and skip this step (right mouse click on label -> skip)
DDLs for tables is here {Builder folder}\Common\MSSQL\v5.3\CreateTables.sql - in script you need to replace {sc} - to your schema name

(belay birlie) #8

Hi Anton,

The builder doesn’t seem to communicate with my database. I have three databases (non_cdm, OHDSI_builder and OMOP_vocab). For CDM database creation I run the query you suggested me ({Builder folder}\Common\MSSQL\v5.3\CreateTables.sql) and it works. For chunk creation step i run the query here {Builder Folder}/CPRDV5/Batch.sql against the OHDSI_builder database and it works.

For look up creation should I run this - {Builders}\CPRDV5\Lookups or \ETL-LambdaBuilder-master\executable\Core\Lookups\Base?

Then for conversion to CDM shouls I run this - ETL-LambdaBuilder-master\sources\Builders\org.ohdsi.cdm.builders.cprd_v5\CPRDV5\Definitions?

Kind regards,

(Anton) #9

Hi Belay,

For others steps you need to use the cdm builder. Do you know why builder cant communicate with databases?


(belay birlie) #10

Ok. I arrive at that conclusion because it works when I run the query.

Just now I Restart chunks creation and run the cdm builder and it take me to the stage where I have never been - Conversion to CDM

(Anton) #11

Can you check Person, observation_period… tables, do they have any records? Copy vocab. step just copying vocab. tables like concept, source_to_concept etc. and can by skipped as well.

(belay birlie) #12

Location and provider table are populated but the others are still empty.

(Anton) #13
  1. Try to restart “Conversion to CDM” step.
  2. If it does no helped, you need to check log table in the cdm builder db.
  3. Which chunk size and degree of parallizm did you use?

(belay birlie) #14
  1. Try to restart “Conversion to CDM” step.

I try ‘reset not finished chunks’ then run builder - gives me the same error message.

  1. If it does no helped, you need to check log table in the cdm builder db.

I have a look in to the log table and it contains the same error message

  1. Which chunk size and degree of parallizm did you use?

I’m not sure about the chunk size. below are the specifications I used
vendor - Cprd v5.3.1
Number of batches- 0
Batch size-1000
MaxDegreeofParallelism -1

Thank you again

(Anton) #15

Oh… whait. Chunk creation step was skipped. This step is required. Unskip Chunk creation step, reset Cdm conversion step, and try run again

(belay birlie) #16

The error message changes now (see below). Such column names exist in the test and additional table.

And the log table

The provider and location table are populated but not the others.

I am really sorry for bothering you a lot

(Anton) #17

Okay, now looks like native scheme mismatch, but I don’t have access to my PC now, and can’t tell you exactly. I will answer on this weekends or Monday.

(belay birlie) #18

Thank you so much Anton!

(Anton) #19

Do you have additional table and test table? Seems that issue with them.

(belay birlie) #20

Yes I have both. I am currently looking at the CDM V5 CPRD mapping specification and I am thinking the datatype might be the reason. Do you think the datatype is specified correctly?