OHDSI Home | Forums | Wiki | Github

ATLAS SNOMED RC and DRC counts populating as 0(zero)


(swethakiran) #1

Hi OHDSI @Ajit_Londhe ,

Our team is exploring the OHDSI tools and very new to it.

After completing the ETL process with the available CMS claims data / synpuff data, we tried to upload the data into the ATLAS. When we are using the search tab in ATLAS and trying to look for vocabularies, for example – diabetes mellitus / hypertension the RC and DC of the snomed record counts are showing as 0(zero) for all of them.

Below is the screen shot.

We are unsure why the values are 0(zero) in Atlas. Can you please help us in identifying the probable cause of this issue?


(Javier Gracia-Tabuenca) #2

hello,

we have the exact same problem (exact same data)

I found this previous conversation ATLAS-Search-RC and DRC are populated as 0

(testing it now)


(Shweta) #3

Check following:

  1. Achilles was run successful.
  2. Achilles_result table is populated.
  3. Check the permissions on table to see if WebAPI can access it.

(Javier Gracia-Tabuenca) #4

thanks @Shweta

We are using the Synpuf tables. Therefore 1 and 2 are correct.
Also the permisions on the tabled are right.

We are using BQ.


(Javier Gracia-Tabuenca) #5

Datasources > Condition, drug exposure and respctive eras also fail

Atlas is unble to read table “concept_hierarchy”


(Shweta) #6
  1. Which version of Atlas and WebAPI ?
  2. Is your vocabulary tables in different schema?

(Javier Gracia-Tabuenca) #7

atlas and webApi 2.7.6

vocab and cdm in same schema


(Javier Gracia-Tabuenca) #8

Ok we found the problem

The JDBC connection was timingout before completing the call.

Solved by

Adding “jdbc:…;Timeout=120;” in the call to the CDM BQ database in table source in webAPI’s postgres database

ref: (https://www.simba.com/products/BigQuery/doc/JDBC_InstallGuide/content/jdbc/bq/options/timeout.htm)


t