OHDSI Home | Forums | Wiki | Github

WhiteRabbit-RabbitInAHat v0.5.0 Mac OS


(Lisa Schilling) #1

Hi all,
WR/RIaH v0.4.5 runs successfully on my Mac OS but not v0.5.0. On the Mac OS, I’ve always had to run through terminal services. Here is the error below. Any ideas?
Lisa

Lisas-MacBook-Air:WhiteRabbit_v0.5.0 lisa$ java -jar WhiteRabbit.jar
Exception in thread “main” java.lang.UnsupportedClassVersionError: org/ohdsi/utilities/WhiteRabbitLauncher : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Lisas-MacBook-Air:WhiteRabbit_v0.5.0 lisa$ …
-bash: …: command not found


(Martijn Schuemie) #2

Hi Lisa. With 0.5.0 we moved from Java version 1.6 to 1.7. I think the default on MacOS is still 1.6 even though that is a really old version. You may need to upgrade.


(Richard Starr) #3

I had the same issue and the upgrade to 1.7 let the app startup. Now I am able to connect to mysql and add the tables from the DB, but I am getting null pointer exceptions when I try to scan them. I have also tried connecting to a csv file and still get the null pointers. This is my first time using white rabbit, so I am not sure if it is me or the new version or something in my java setup.
Can you let me know if you have success after you upgrade?
Thanks!


(Richard Starr) #4

I downloaded the v4.5 and am able to get a scan of csv files and mysql tables. So it looks like an issue with v5.0 or with the Mac OS X 1.7 java installation and v5.0.


(Ryan Duryea) #5

@Richard_Starr, when I attempted to recreate your error, I found what might be the same bug and reported it here. Please take a look and let me know if this is the same behavior you were seeing.

Thanks!


(Ryan Duryea) #6

@schuemie, I’ve bump the Java version in the README to 1.7


(Richard Starr) #7

It seems to be the same. Here is the output from a csv attempt. It is using the complete path.

Jun 24, 2015 12:46:10 PM Scanning table /Users/rstarr/Downloads/WhiteRabbit_v0.5.0/list.csv
Jun 24, 2015 12:46:10 PM Scanning table /Users/rstarr/Downloads/WhiteRabbit_v0.5.0/list.csv
Error: null
Jun 24, 2015 12:46:10 PM Scanning table /Users/rstarr/Downloads/WhiteRabbit_v0.5.0/list.csv
Error: null
Exception in thread “Thread-0” java.lang.NullPointerException


(Mac Christmas) #8

This post was flagged by the community and is temporarily hidden.


t