OHDSI Home | Forums | Wiki | Github

WhiteRabbit Issue java.lang.NoSuchMethodError

Hi there,

I am quite new at using WhiteRabbit & ETL tools. I simply would like to generate a ScanReport from simple Synthea csv files. The scan fail while generating the scan report and return an error:

Exception in thread “Thread-2” java.lang.NoSuchMethodError: ‘org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFontFamily org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFont.addNewFamily()’

It also list some further issues:

at org.apache.poi.xssf.usermodel.XSSFFont.setFamily(XSSFFont.java:635)
at org.apache.poi.xssf.usermodel.XSSFFont.setFamily(XSSFFont.java:647)
at org.apache.poi.xssf.model.StylesTable.createDefaultFont(StylesTable.java:765)
at org.apache.poi.xssf.model.StylesTable.initialize(StylesTable.java:716)
at org.apache.poi.xssf.model.StylesTable.(StylesTable.java:130)
at org.apache.poi.ooxml.POIXMLFactory.newDocumentPart(POIXMLFactory.java:94)
at org.apache.poi.ooxml.POIXMLDocumentPart.createRelationship(POIXMLDocumentPart.java:591)
at org.apache.poi.ooxml.POIXMLDocumentPart.createRelationship(POIXMLDocumentPart.java:500)
at org.apache.poi.xssf.usermodel.XSSFWorkbook.onWorkbookCreate(XSSFWorkbook.java:465)
at org.apache.poi.xssf.usermodel.XSSFWorkbook.(XSSFWorkbook.java:255)
at org.apache.poi.xssf.usermodel.XSSFWorkbook.(XSSFWorkbook.java:249)
at org.apache.poi.xssf.usermodel.XSSFWorkbook.(XSSFWorkbook.java:237)
at org.apache.poi.xssf.streaming.SXSSFWorkbook.(SXSSFWorkbook.java:256)
at org.apache.poi.xssf.streaming.SXSSFWorkbook.(SXSSFWorkbook.java:226)
at org.apache.poi.xssf.streaming.SXSSFWorkbook.(SXSSFWorkbook.java:201)
at org.apache.poi.xssf.streaming.SXSSFWorkbook.(SXSSFWorkbook.java:288)
at org.ohdsi.whiteRabbit.scan.SourceDataScan.generateReport(SourceDataScan.java:172)
at org.ohdsi.whiteRabbit.scan.SourceDataScan.process(SourceDataScan.java:117)
at org.ohdsi.whiteRabbit.WhiteRabbitMain$ScanThread.run(WhiteRabbitMain.java:1048)

I did not find a way to fix this issue yet.

I am using macOS Monterey 12.0.1 (Intel MacBook Pro).
java version “17.0.1” 2021-10-19 LTS

Hi @coddy33
Try Java 1.8
I hope it will help

@coddy33 What version of WhiteRabbit (and indeed Java) are you using?

WhiteRabbit v0.10.5
Java 1.8

1 Like

Hi @coddy33,

As @Reza_Baharmand mentioned earlier… I had to face the same error when I was using Java 16 version then I moved to Java 8 Version. It worked. Hope this will help you too.

Kind regards,
Dinuja S’Wickrama


Thank you all, it’s working indeed with:

  • WhiteRabbit v0.10.5
  • Java 1.8

I confirm that the the last version of WhiteRabbit (v0.10.5) is also mandatory. v0.10.4 is not working even with Java8.

If anyone encounter the same issue, you will find Java8 on the official Oracle archives.

# You can now list all your local Java version 
/usr/libexec/java_home -V

# And switch to the one you need 
export JAVA_HOME="/usr/libexec/java_home -v 1.8"

:warning: make sure you are running WhiteRabbit v0.10.5 or higher

1 Like