OHDSI Home | Forums | Wiki | Github

Webapi - no connection to vocabulary [updated but not solved]

Dear Community,

I would like to ask you if it is a normal operation or there is something I need to fix.

I have a perfectly working full Microsoft Deployment (Win +MSSQL), which shows vocabularies on the search page:

The Atlas config page looks like this:

And I have a CentOS7 + Postgres 10 deployment, which works, but does not show the vocabs:

Search page: no vocabularies available:

And here is the configuration:

As I search on this CentOS7/Postgres10 config, the vocabs are there but first I have to check at least one domain in the advanced search mode (e.g. condition). After I got results in the small window I can see the vocabs too, but still not on the main search page:

So probably the database is Ok, connections are OK, but something can be wrong with this postgre version.

  • I’m working with the 2.9.1 version WebAPI and Atlas.
  • both installations have no records in the CDM at the moment

Thank you in advance.