OHDSI Home | Forums | Wiki | Github

Vocabulary file format


(Arun babu Rajeswaran) #1

Hi
I have downloaded omop standard vocabularies into my laptop.
When I opened the files in notepad, I see that the values are separated by tabs rather than commas.
And I am not able to import the table into postgresql thorough pgadmin 4. It gives an error message- “import failed exit code1”

What can do about it?
Can anyone please guide me how to import the vocabulary files into postgresql database?
Thanks


(Seng Chan You) #2

We’ve developed a package to upload OMOP voca to the SQL DB, OmopVocaManager.
Could you try to upload vocabulary to DB by using this package?


(Arun babu Rajeswaran) #3

thanks for the reply.
I tried it.
But I’m getting an error

“Error: Failed to install ‘OmopVocaManager’ from GitHub:
(converted from warning) installation of package ‘C:/Users/draru/AppData/Local/Temp/Rtmpacor9y/file297c43fd6640/OmopVocaManager_0.9.5.tar.gz’ had non-zero exit status”


(Yeon Chan Seong) #4

Hi,
I’ve just tried to install OmopVocaManager, and it worked.

In my experience, the error showed up when there’s no dependencies or previous version of the package(or other dependencies) was installed.

Is there any massages before your error like “Try removing ‘C:/Users/…/<package name>’”(The message may not start with ‘Try removing’)? If there is, you can follow the direction.

20.03.10 +) I updated latest version of OmopVocaManager. Please use latest version :slight_smile:


t