OHDSI Home | Forums | Wiki | Github

Unable to save concept set

atlas

(Anoop Yamsani) #1

When trying to create concept sets, Different users with same roles are experiencing different things. Some users are able to create concept sets where as other are facing error ‘Unable to save concept set’. To test it out i even provided the user with admin role along with all roles available out of the box and access to the source, still having the same error ‘Unable to save concept set’. OMOP CDM version : 5.3 and Atlas version is 2.7.3. Upgrading Atlas may not be a immediate solution, so wondering if any one has come across this issue before, if so, how were you able to resolve this? Any help is much appreciated.


(Konstantin Yaroshovets) #2

Hi @anoop.yamsani ,

We know about the issue. It’s related to the case that owner of concept set can edit it only. ATLAS does not provide correct description of the error when other users try to save the object. If you need to give other users ability to edit concept sets created by other users, you can grant them “Concept set creator” role.


(Anoop Yamsani) #3

@Konstantin_Yaroshove Thank you very much for the quick response. Unfortunately, in our case we have some users who have all roles available under ATLAS and they still see the Error message that they cannot save the concept set, this is a brand new concept set that they are creating and still get the error, where as some other users with same privileges are able to save them with no issues at all.


(Konstantin Yaroshovets) #4

@anoop.yamsani I will reach you by email to investigate the problem.


(Anoop Yamsani) #5

Thank you @Konstantin_Yaroshove . My email id is anoop.yamsani@cuanschutz.edu .


t