OHDSI Home | Forums | Wiki | Github

Rabbit in hat- Generate-Generating an ETL Document

I am facing challenge here. I have just mapped person table and wanted to generate ETL document once started this, keeps on running for ages and no action. Please suggest solution.

One more - Suppose i am not getting all data once and sometimes my white report is not on all CDM objects. Can I do merging in white rabbit report as I get files from source and can same applies with rabbit -in -Hat.

Example - today i got patient data and generated ETL Document. Next time i have to append Visit_occurance to same document. Is it possible?


Dear Chanchal,
which version of WhiteRabbit are you using? The step to generate the ETL document should be very quick, especially if it is for one table mapping.
For the White rabbit reports, you can merge different excel files as long as you don’t change the format of the columns and tabs. Then you should be able to load the new file still to Rabbit in a Hat.
For the ETL document you can always manually update the word or markdown documents that you already produced (except the pictures). Hoverer I m not aware if you can update the ETL specs file with more source tables.

HI Sofia,

I am using WhiteRabbit_v0.10.5 and tried again and its just clocking an not generating any file.Steps followed.

  1. Generated report using synthea patient csv file from white rabbit.
  2. Saved file as excel workbook
  3. opened Rabbit-in -hat and selected the report generated
  4. Just mapped person table an mapped some columns not all.
  5. saved the file (file - > save)
  6. Generate → ETL document → gave file name and after that nothing happns.

Please advice.

You can try to use some earlier versions of the White rabbit. Also you can submit an issue in the White rabbit github

Hi Chanchal,

As Dmytry already said the best option is to use an older version of the tools. I checked and both releases 10.4 and 10.5 seem to have the same issue when trying to generate an ETL Word document. To generate the markdown files it seems ok however.
I would recommend you use the 10.3 release, for me that works as expected: https://github.com/OHDSI/WhiteRabbit/releases/tag/v0.10.3
And create an issue in github.

Thank you, I can use Rabbit-in-hat V0.10.3 but it doesn’t support CDM V5.4. :frowning:

I will create issue in git for latest RiH.

Hi @Chanchal.Dixit, we have investigated and solved the underlying issue. We are currently testing and hope to make a new release coming Monday.

@Chanchal.Dixit The issue has been fixed in the new release of WhiteRabbit and Rabbit-in-a-Hat: https://github.com/OHDSI/WhiteRabbit/releases/tag/v0.10.6

Thanks for reporting!

Thank you very much for this resolution. It helped me a lot.