OHDSI Home | Forums | Wiki | Github

R packages -Loading required package: ggplot2 Error in dyn.load(file, DLLpath = DLLpath, ...) :


(Giorgio Oliviero) #1

Hi There,
I am very appreciated to share this problem and also someone could help me to fix it :smile:

Mac OS X 10.7.5
Rstudio Version 1.1.463
R version 3.2.1 (2015-06-18)

Error in dyn.load(file, DLLpath = DLLpath, …) :
unable to load shared object ‘/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rlang/libs/rlang.so’:
dlopen(/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rlang/libs/rlang.so, 6): Library not loaded: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libR.dylib
Referenced from: /Library/Frameworks/R.framework/Versions/3.2/Resources/library/rlang/libs/rlang.so
Reason: Incompatible library version: rlang.so requires version 3.5.0 or later, but libR.dylib provides version 3.2.0
In addition: Warning message:
package ‘ggplot2’ was built under R version 3.5.2
Error: package or namespace load failed for ‘ggplot2’


(Ajit Londhe) #2

Looks like you need R version 3.5.2 or above


t