OHDSI Home | Forums | Wiki | Github

Problem deploying WebAPI on docker on a Synology NAS

Dear all,

We are trying to deploy WebAPI and Atlas on an infrastructure which consist of a Synology NAS able to run docker images. From an hardware point of view, the Synology seems to be capable enough (Intel CPU, enough RAM).

We have deployed Tomcat and Postgresql on the NAS, here is a short summary of where we are :

  • We are in the process of deploying WebAPI and Atlas
  • Tomcat and Postgresql have been deployed on Docker on a Synology server
  • Postgresql database has been prepared for WebAPI
  • WebAPI has been compiled with corresponding settings
  • We have tried to deploy WebAPI on Tomcat

However, we are now facing an unexpected issue. WebAPI is not responding (we get a 404 error), and the Tomcat logs are almost empty regarding WebAPI (only a line telling that the deployment starts, and another that the deployment ends). We have tried to compile WebAPI from two differents computers with different systems, the result is the same.

This seems really strange because this application should output quite a lot of stuff in the output when it’s deployed. I already deployed the software on another more “standard” setup (Ubuntu VM). It was quite tedious to get WebAPI to work, but at least there where tomcat logs to guide me in the process. Here nothing that we can found.

Does anyone encountered a similar problem ? Could it be due to docker getting in the way, or the Synology hardware ?

Any help is appreciated,
Thank you

If you’re able to run Docker, I’d suggest going with a full Dockerized deployment of Atlas, using Broadsea, which covers Atlas, Tomcat, Postgres all in one big docker compose. This isn’t to necessarily fix your issue, but it’s a lot easier than trying the traditional way of Atlas deployment.

Thanks for your suggestion, I will have a look a this solution.