OHDSI Home | Forums | Wiki | Github

OHDSI Atlas logout issue

Hi Team,

We have configured LDAP and DB authentication in our OHDSI Atlas.
Whenever we logged into ohdsi using LDAP or as a DB user, For every refresh it is logging out the users!

Is there any specific configuration we need to do in our Docker-compose?
We are using Broadsea 3.0 in our environment
Versions of Atlas and WebAPI
Atlas: v2.13.0
WebAPI: v2.13.0

We can also share the docker-compose contents and logs for your reference if needed
Please help us to resolve this issue!

Kavi Sambathkumar

Are your browsers set to disable caching? If not, then perhaps there’s a WebAPI parameter we need to set.

Hi @Ajit_Londhe ,

Thanks a lot for your quick response, We are not disabling cache in browser
If there’s a parameter needs to be set for WebAPI container to resolve this issue, please share it and that will be very helpful for us

Can you try adding this to the ohdsi-webapi.yml environment section? Then delete the container and try the docker compose command again.


This would set it to 8 hours. I’m raising a Git issue in Broadsea to add this as an option.

Hi @Ajit_Londhe ,

I’ve tried the above parameter for WebAPI, But still we are facing the same

Ah, we just discovered that there’s an old setting from Broadsea 2.0 that causes the Atlas local caching of the session token to be disabled.

I’ve added this fix to the develop branch, but you can also make the change to your existing deployment by removing this line, and then completely re-deploying the ohdsi-atlas container:

Hi @Ajit_Londhe ,

Thank you so much, This helped us a lot for us!

1 Like

Hi @Ajit_Londhe ,

Whenever we try to access OHDSI Atlas via browser, For some users it is taking long time ( approx. 5 to 10 mins )
But for some users it is very faster
Do we need to enable/disable something in browser settings or in docker-compose env variables?

Try clearing the cookies for the users experiencing long load times. If still persisting, can you provide any console errors from the browser?

Hi @Ajit_Londhe ,

We’ve cleared the browser cookies, Apart from that it seems to be a 401 response for me in browser console and all other things seems to be fine with 200 response


That one is expected. It fails first before the log in is successful.

Glad to hear it worked! Please raise any issues faced in the GitHub repo.