OHDSI Home | Forums | Wiki | Github

No data in some reports in atlas

We have some issues in getting back some of the report.

  • There is no error in the developers section and the respond is empty list.
    The problem is also in others reports.

This is the sources json:
[{“sourceId”:1,“sourceName”:“Hadassha CDM”,“sourceDialect”:“postgresql”,“sourceKey”:“omop_demo”,“daimons”:[{“sourceDaimonId”:1,“daimonType”:“CDM”,“tableQualifier”:“omop_demo”,“priority”:0},{“sourceDaimonId”:2,“daimonType”:“Vocabulary”,“tableQualifier”:“omop_demo”,“priority”:1},{“sourceDaimonId”:3,“daimonType”:“Results”,“tableQualifier”:“results”,“priority”:1},{“sourceDaimonId”:4,“daimonType”:“Temp”,“tableQualifier”:“temp”,“priority”:0}]}]



Hello @Almog_Sarafian,

Just-in-case question: have you run Achilles on your CDM data? In ATLAS docs, it’s mentioned that this is a required step in order to use Data Sources reports in ATLAS.

Hello @rookie_crewkie
Thanks for you answer.

My name is Tom, I am working with Almog.
We run Achilles and all test finished without errors.

Thanks again,
Tom .

You might also be having problems with Atlas’ permissions
This can be modified at the Atlas’s configuration option.

Hello @Tom_Dua,

Can you see at least some of the reports or none at all? Recently there was a similar thread where only Person report was available, the issue was due to missing Observation Period records. The code for data density in Achilles relies on data collected by analysis queries that also involve Observation Period.

Database user permissions seem to be fine, otherwise ATLAS would display ‘Error loading report’ message instead of an empty report. Might be worth checking ATLAS’s own permissions, as proposed by @jcabrerazuniga.

1 Like

Hello @rookie_crewkie & @jcabrerazuniga ,
Here atlas configuration:

We can see some of the reports like: Person, Observation, Observation Period & Death. The Other reports present “no data”.

Can you see a “Manage Permissions” button? If you can’t, you might need to change your account permissions for administrator privileges or something similar at the database.

1 Like

We have administrator privileges, so we don’t understand were is the problem.


Hi @rookie_crewkie @jcabrerazuniga

Do you have any more ideas please?

Thanks ,

Hi - have you confirmed that the concept_hierarchy table is created in your results schema as described on https://github.com/OHDSI/WebAPI/wiki/CDM-Configuration#results-schema-setup? Specifically the initConceptHierarchy flag, when set to true, will give you some extra SQL to build this table. concept_hierarchy is used by some of the Data Sources reports and perhaps it was not populated when you set up the results schema?

Hi @anthonysena
Thanks for your answer.
We did as you said and according to the setup guide.
Screen shot from concept_hierarchy results schema.

You can see that the drugs are defined, but we do not see the report on the drugs in atlas.

Thanks @Tom_Dua for sharing that - I see the problem. The columns that are NULL (i.e. level1_concept_name, etc) should be populated with values which indicates that you may be missing some vocabulary entries.

I was looking at https://api.ohdsi.org/WebAPI/ddl/results which is used to create the results schema tables and populate concept_hierarchy. In the queries, you will see that we make use of some classification vocabularies to build this hierarchy. Specifically, MedDRA for conditions and ATC for drugs. If you could download those vocabluaries and rebuild the concept_hierarchy that should help resolve conditions/drugs. If you have procedures/measurements/observation in your data, are those reports working?

Hi @anthonysena ,
We don’t have the MedDRA vocab but we have the ATC for the drugs and still cant see the data.
We have also problem with the measurement & visit & data density.
Thanks a lot,

I do not have direct experience, but in the past month or two I remember a thread about a report or table creation issue to which the resolution was downloading additional vocabularies. My memory was that some vocabularies that are represented as optional are in fact required. I’ve tried searching for the thread but am unable to find it. Perhaps this message will prompt someone’s memory who contributed to that thread.

@Almog_Sarafian - here are the relevant queries used by WebAPI for those reports. You may need to run them manually to see where the problem(s) lie:

Data Density: WebAPI/src/main/resources/resources/cdmresults/sql/report/datadensity at master · OHDSI/WebAPI · GitHub



Hi, @anthonysena or someone who can help

I have similar situation for our Atlas: No data for some reports. I’ve been working on this problem for a while and now not sure what should do to solve the problem. Any suggestion is really appreciated.

Here is the current status and what I did:
The following report have data displayed in Atlas:
Dashboard, visit, Condition Occurrence, Procedure, Measurement, death
The following reports have “no data”:
Data Density, Person, Condition Era, Drug Exposure, Drug Era, Observation.

Here is what I did to generate the reports:
Ran Achilles R function dropAllScratchTables() to drop all the tmp tables.
Then ran the SQLs generated from

And next run the SQLs generated and modified from the Achilles function
cdmDatabaseSchema = "cdm ",
vocabDatabaseSchema = “cdm”,
numThreads = 12,
sourceName = “OMOP”,
cdmVersion = “5.3.0”,
analysisIds = voOnly,
sqlOnly = TRUE)

All the SQLs are completed without any error.

I tried the following R functions to check the reports and they look good in json files. One of these functions is exportPersonToJson() è person.json

I also ran the SQLs under …/ webapps/WebAPI/WEB-INF/classes/resources/cdmresults/sql/report/person
yearofbirth_stats.sql, yearofbirth_data.sql,
race.sql, population.sql, gender.sql, ethnicity.sql
and all got results.


Hi @waxwlg, how did you create the voOnly variable that you passed to the analysisIds parameter? Probably the analyses needed for the data density plots were not included there.