OHDSI Home | Forums | Wiki | Github

Issues in Running the Achilles indicating the cdm tables not set

Hi am still new in the set up and use of Achilles and Atlas. I have my atlas configured having the webAPI database already set.
I have followed CDM configuration and created the required tables for the cdm database setup.
Since am using PostgreSQL I worked with the importation of the vocabulary following the following guide CDM Postgresql which the query run was success.
However when running Achilles to characterize my CDM data shows the following errors.

2021-04-08 12:50:55 Analysis 2201 (Number of note records, by note_type_concept_id) – START
| | 0%2021-04-08 11:50:56 Analysis 2201 – ERROR Error in FALSE: Error executing SQL:
org.postgresql.util.PSQLException: ERROR: relation “cdm.note” does not exist
Position: 371
An error report has been created at c:/RBuildTools/temp/achillesError_2201.txt

Error in $<-.data.frame(*tmp*, “runTime”, value = NA) :
replacement has 1 row, data has 0
achillesError_0.xml (1000 Bytes)

an indication that the cdm database values was not set. Attached is a sample of one of the acchillesError.txt

I also tried to configure the cdm by running the appropriate cdm but it indicate the vocab.concept not present. I don’t get it where am going wrong in the configuration.

Below is a sample of my database setup.

Kindly someone to help me out.

For running achilles, you can ignore the WebAPI setup and configuration.

The error is this:

org.postgresql.util.PSQLException: ERROR: relation “cdm.note” does not exist

Can you confirm that cdm.note table exists?

From your error log you attached, it says:

org.postgresql.util.PSQLException: ERROR: relation "cdm.person" does not exist
  Position: 367

Can you confirm the table cdm.person exists?