OHDSI Home | Forums | Wiki | Github

Issue in Importing Concept sets to Cohort Definitions


I have been working on Atlas. I am facing issue in importing the concept sets into Cohort Definitions . Its been loading for a while. Currently I am using Linux Server. I have installed Atlas using Broadsea.
I would Appreciate your Support for my issue

Can you please open up your console and see if there are any errors reported, and submit it here. It’s hard to diagnose the issue with the limited information you provided.

Heres the console info

The 500 errors inidcate that you should see an exception in the server logs. To make it easier for you to find it, you might want to stop your webAPI service, delete the logs, restart webapi, and then trigger the UI error again. Then you should have a relatively short log file in webapi to find the exception.

Hi @Chris_Knoll
I have followed all your instructions . But still facing the same issue . Below i have attached few screenshots for the reference in detail.

So, this is a new one to me! The error:

Current datasource does not contain the required concepts (4118910, 4167493)

I need to dig through the source code to determine where that message is produced, but I’m not sure what would make a concept ‘required’ in a datasource. But it looks like that is preventing the operation.

I am using ATLAS DEMO version (ATLAS) for sometime to build concept sets and I found something amiss recently. When I search for a drug ‘tremelimumab’ in ATLAS I am seeing fewer concepts than in ATHENA. Just wanted to check if I can rely on Demo version to build concept sets or I should have a own version installed.
I am not sure if this is the correct place to discuss this, please direct me to correct discussion thread.

The ATLAS demo application has now been updated with the latest OMOP CDM vocabulary release.
It is intended just as a demo, so installing your own version is recommended.

hi @Chris_Knoll
When I tried to dig deeper into the logs of webapi . I have found this

Can you please let me know is there any other options to solve this issue ?

did u fix it? i have the same issue

Since you’re on Broadsea, I don’t have a lot of knowledge related to how to diagnose those issues. @Ajit_Londhe or @admin might have tips, but the error message is clearly stating that it is unable to connect to the database. I thought all this was pre-configured in Broadsea, so unless you made customizations to the configuration, I’m not sure what is happening there.

not yet. still facing the issue

I solved uploading my vocabulary in atlas.postgres.demo_cdm
I couldn’t find the right path to change the vocabulary so i tried this way,
populating the vocabulary table (in your case, I see you miss values in the table concept as in my case), I managed to create the cohort


I encountered the same issue here. To solve it, I simply changed the “priority” value to the highest in the daimon_source table.