OHDSI Home | Forums | Wiki | Github

Invalid object name 'results.achilles_result_concept_count'

Hi,

I’m setting up a new install of OMPO and ATLAS, etc and have followed all the relevant instructions to:

  • Create database with Athena vocabs in (MSSQL database)
  • Add results schema
  • Apply results schema DDL from WebAPI end point
  • Run Athena R script

I can access all the data Sources, including Achilles Heel, but when I click on “Cohort Definitions” the page hangs and the following error appears in the tomcat logs

2021-05-14 10:52:31.108 ERROR taskExecutor-1 org.ohdsi.webapi.cdmresults.CDMResultsCacheTasklet - - Failed to warm cache for KCLSLSR. Exception: PreparedStatementCallback; bad SQL grammar [SELECT
concept_id,
record_count,
descendant_record_count
FROM results.achilles_result_concept_count]; nested exception is com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name ‘results.achilles_result_concept_count’.
2021-05-14 10:52:31.109 WARN taskExecutor-1 org.ohdsi.webapi.cdmresults.CDMResultsCacheTasklet - - Failed to warm cache for KCLSLSR. Trying to execute caching from scratch. Exception: PreparedStatementCallback; bad SQL grammar [SELECT
concept_id,
record_count,
descendant_record_count
FROM results.achilles_result_concept_count]; nested exception is com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name ‘results.achilles_result_concept_count’.

The Table does not exist in the database. The following tables are in the database with a similar name

Name Schema
ACHILLES_analysis results
achilles_heel_results results
achilles_results results
achilles_results_derived results
achilles_results_dist results

Any ideas what I’ve missed or where in the process the achilles_result_concept_count table should be created?

Answering my own question. When running achilles set the parameter optimizeAtlasCache = TRUE (its FALSE by default)

Doing this seems to have created the table

t