OHDSI Home | Forums | Wiki | Github

I cannot open the graphical interface of WhiteRabbit and Rabbit-In-a-Hat on Linux (Ubuntu)

Hello everyone,

I am trying to use WhiteRabbit and Rabbit-In-a-Hat on Linux (Ubuntu) but I can’t get the graphical interface to open. When I double click on the file as indicated in the documentation (White Rabbit) it simply opens in a text editor.

I have tried launching WhiteRabbit from the command line and it worked but Rabbit-In-a-Hat is a tool that can only be run through the graphical interface.

Is this a bug?
How can I run the graphical interface of these tools on Linux (Ubuntu)?

Thanks in advance.

Both programs are simple Java applications that should run pretty much on any platform. What Java version are you running? What does the textbox say when you double-click the Jar file?

I have been able to run the programs by simply typing in the command line the name of the program without using any parameters, i.e. bin/whiteRabbit or bin/rabbitInAHat. I had previously used other instructions but this is the one that works (I have to thank @janblom of the WhiteRabbit GitHub repository for the suggestion).

Thanks for the help in any case.

It is possible that Ubuntu stopped recognized files by content and resorts to looking up only filename extensions. Does it work if you rename bin/whiteRabbit to bin/whiteRabbit.sh?

I just tried it and it doesn’t work that way either but thanks for the suggestion. In any case I have been able to run the programs as indicated in my previous message.

Linux never uses extensions; one may have an application that does, but that is not the base system. Linux uses magic numbers at the head of the file.

~More likely the file is set to be non executable. Run ls -l in your dir.~

Never mind, if it was not set to executable, then one could not run it from the shell.

I am an Arch user, so I had to look up how Ubuntu does its clickable exe, here is an entry showing how to set up your file in Ubuntu to be clickable: launcher - How to execute a script just by double clicking like .EXE files in Windows? - Ask Ubuntu