OHDSI Home | Forums | Wiki | Github

Fatal error when running Achilles on RStudio instance - OHDSIonAWS

Every time I run Achilles using the database connector to connect to Amazon Redshift, I receive a fatal error before the entire run can complete that states the following:
Error: 'makeCluster' is not an exported object from 'namespace:OhdsiRTools'

Below are the parameters used when running Achilles:

achilles(connectionDetails = connectionDetails,
         cdmDatabaseSchema = "study",
         resultsDatabaseSchema = "studyresults",
         scratchDatabaseSchema = "studyresults",
         vocabDatabaseSchema = "study",
         createTable = TRUE,
         createIndices = TRUE,
         cdmVersion = 5.3,
         numThreads = 1,
         dropScratchTables = TRUE,
         runHeel = FALSE)

From what I can see, the makeCluster object is from the ParallelLogger package, and this package should only be utilized when running in multi-thread mode. There must be some sort of bug that is causing this behavior. I’ve logged this as an issue in GitHub as well.

I am using Achilles version 1.6.3

Hi Michael - I’ve experienced the same error with a recent AWS installation, when numThreads>1. Have you been able to find an answer to the issue?

makeCluster has been moved from OhdsiRTools to ParallelLogger package. I would try to update Achilles version (1.6.7).

Thank you Ajit. I’ll upgrade later this week and let you know how it goes.

I apologize for not replying earlier. I was encountering this issue when the numThreads was set to 1; never tried with more than that. I was instructed via the GitHub repo to update to the beta version of Achilles 1.7. After doing this, the problem was resolved. The command to force install to 1.7 is as follows from the R console: