OHDSI Home | Forums | Wiki | Github

Error running Data Quality Dashboard script on RStudio


(Barış Erdoğan) #1

Hi Everyone,
In a Win10 environment, I have R-4.0.3-win, RStudio-1.3.1093, and rtools40-x86_64 installed.
R Tools is set as a Path variable.
I executed the following on RStudio:
install.packages(“devtools”)
devtools::install_github(“OHDSI/DataQualityDashboard”)
devtools::install_github(“OHDSI/DatabaseConnector”)
devtools::install_github(“OHDSI/SqlRender”)

I have a PostgreSQL CDM database on a server.

When I run DataQualityDashboard script I get the following errror:

DataQualityDashboard::executeDqChecks(connectionDetails = connectionDetails,

  •                                   cdmDatabaseSchema = cdmDatabaseSchema, 
    
  •                                   resultsDatabaseSchema = resultsDatabaseSchema,
    
  •                                   cdmSourceName = cdmSourceName, 
    
  •                                   numThreads = numThreads,
    
  •                                   sqlOnly = sqlOnly, 
    
  •                                   outputFolder = outputFolder, 
    
  •                                   verboseMode = verboseMode,
    
  •                                   writeToTable = writeToTable,
    
  •                                   checkLevels = checkLevels,
    
  •                                   checkNames = checkNames)
    

Connecting using PostgreSQL driver
Error in rJava::.jcall(jdbcDriver, “Ljava/sql/Connection;”, “connect”, :
org.postgresql.util.PSQLException: SCRAM authentication is not supported by this driver. You need JDK >= 8 and pgjdbc >= 42.2.0 (not “.jre” versions)

Can someone help?


(Dave Barman) #2

I have not encountered this error before. I would start with reinstalling the rJava package though. If you’ve already done that and you are still having this error, take a look at the JAVA version on your machine as well.

Please post back if you are still having issues!


(Fraser Gaspar) #3

I have also run into this problem. I reinstalled rJava. I have Java JDK 15.0.1 version. I downloaded the latest pgjdbc (42.2.18) and put it into the Java extensions folder. But when trying to connect to my Postgres server, I still get error. Any tips would be appreciated. Thanks!


(Barış Erdoğan) #4

Hi,

I fixed my problem by manually setting JAVA_HOME as below, right before setting the connectionDetails:

options(java.home=“C:\Program Files\Java\jdk-14.0.2\bin\”)


t