OHDSI Home | Forums | Wiki | Github

Cohort Generation in Atlas with Generation status Failed


(Chris Knoll) #41

Hi, Ty,
I think you can proceed with those proposed GRANT commands, I’m not sure what problems might arise due to the disabled option, but we can always apply permissions later. The most important part of the instructions is where it says you need to login in as the ohdsi_admin_user in the section on ‘prepare database schema for WebAPI’. This is because there will be default permissions granted for the schema based on who you’re connected as (this is a wierd PG thing). Just make sure you’re connected as the ohdsi_admin account, since this is the account that will be used by WebAPI to create tables within the schema you are creating. I can’t quite tell who you’re connected as, but this has caught others in the past.

After you have that schema set up with the GRANTs, you should be clear to launch the WebAPI process (after you finish the instructions of gettting that built with your own local configuration), and once WebAPI starts, you should see tables created for you in the webapi schema automatically.

Or, you’ll get an error, and you’ll tell me what it is and we’ll fix it :).


(Ty) #42

Hi Chris. Sorry have not looked at this for a little bit but I will update you when I get back to it. Sincerely thank you for your help so far. Ty


(Ty) #43

Hi @Chris_Knoll

Just thought I’d let you know I have a local instance of Atlas running via WebAPI and those Postgres privileges worked no problems!

Re: the “login in as the ohdsi_admin_user” hint (thank you), I did some googling and for those that didn’t know like me - when in pgAdmin you can only log in as the default admin user in a traditional sense (and can’t change users) but “login in as the ohdsi_admin_user” means make all the changes in the newly created local host - ohdsi_admin_user server (screenshot from the postgres guide).

I think in hindsight, the Broadsea approach may have worked too, it’s just that there are some additional steps I would have only known about by bugging people on this forum or understanding the WebAPI steps to fill in the steps not covered by Broadsea if that makes sense.

Thanks again for your help!
Ty


t