OHDSI Home | Forums | Wiki | Github

"Charateriztions" didn't working In WebAPI ver.2.6 & WebAPI 2.72 can not build!


(Park,CHANGHYUN) #1

Hi
I’m a Developer for Atlas Settings .

It is our DEV Environment :
DBMS : oracle 12.2.0.1
os: window server
Atlas:2.6
WebAPI:2.6

I want to use characteristic function in ATLAS. But it didn’t work.
It is a image about error when I try store Characteristic.


I think , this error are solved by upgrading WebAPI(ver.2.72 now 2.6).
So I try WebAPI 2.72 building to MAVEN.
But it occurred error.

It is a error image .
image

please give me hand~!


(Chris Knoll) #2

I found this information about pulling the JDBC driver from oracle’s maven repo:

https://blogs.oracle.com/dev2dev/get-oracle-jdbc-drivers-and-ucp-from-oracle-maven-repository-without-ides

I think to get this to work for us, we would need to update our dependencies reference in pom.xml to reference the correct artifact ID and version. Developers would be required to specify their oracle maven identity (from http://maven.oracle.com) in a local settings.xml file so that the user can authenticate to download official drivers.

Alternatively, if we could get some kind of permission to host it on our own nexus repository, then we would be able to host the libraries ourselves. I just don’t know how we could get the necessary permissions.


(Park,CHANGHYUN) #3

Thanks for @Cris_Knoll I solved this problem.

I fixed maven repository setting.(url-> locally)

It is step of solution.

1. download ojbdc file in my computer (from oracle homepage)
2.type starting “mvn install” commend line ->for setting local repository about ojdbc

(reference url: https://yasol.tistory.com/entry/maven을-이용하여-ojdbc8-JDBC-추가-set-ojdbc8-jdbc-library-on-pomxml-through-maven)

image

3. adjust pom.xml file in WebAPI

image

Somebody who face similar problem , reference this Reply.


t