OHDSI Home | Forums | Wiki | Github

Build of WebAPI (Docker-Image) fails due to missing artifact

Hi dear community,

i just tried to build the WebAPI 2.8.2 in a Docker Build-Image. After some minutes of downloading the packages the process fails with the following message:

“[ERROR] Failed to execute goal com.qmino:miredot-plugin:2.2:restdoc (default) on project WebAPI: Execution default of goal com.qmino:miredot-plugin:2.2:restdoc failed: Plugin com.qmino:miredot-plugin:2.2 or one of its dependencies could not be resolved: Could not find artifact com.sun:tools:jar:1.6.0 at specified path /usr/local/openjdk-11/…/lib/tools.jar -> [Help 1]”

Has anybody experienced the same problem? Until now I used the direct download of the WebAPI.war, but wanted to switch over to the dockerized way.

First i downloaded the current release from github. Then I tried to build the API. Here is my maven command:

mvn clean package -s WebAPIConfig/settings.xml -P webapi-postgresql -DskipTests -DskipUnitTests=true -DskipITtests=true

Kind regards,

Mirko

The build must be done on JDK8. From your path, it looks like it is using JDK11.

The com.sun.tools is something that is included in JDK8, but not in future versions. When we migrate our WebAPI dependencies (and JRE) to later versions, we should be able to use later JDKs for building.

Thanks a lot. That did the trick.

t