OHDSI Home | Forums | Wiki | Github

Atlas 설치후 오류


(Donghun Kyeong) #1

안녕하세요, 국립암센터 연구원 경동훈입니다.
현재 VM으로 Atlas, Achilles를 구축해보고 있습니다.
여러 검색을 했으나 정보를 찾지 못하여 도움을 얻고자 글을 남깁니다.
문제는 아래와 같습니다.

Atlas를 설치후 home 은 보입니다.
개발자모드를 보면 notification을 찾지 못했다는 에러가 나옵니다.
서버에서 index.js를 찾아야 하는것인지, WebAPI 설정의 문제인지 감을 못잡고 있습니다.
DB는 Postgresql을 사용중이며 서버는 Windows2012입니다.

감사합니다.


(Donghun Kyeong) #2

WebAPI 문제인가 싶어서 추가로 글을 남깁니다.
WebAPI/source/source 에서 insert한 값이 나오지 않고 있습니다.

현재 DB는 두개입니다. 스키마는 두개 모두 public 입니다.

  • OMOP CDMv5 의 ‘ohdsi’
  • WebAPI를 빌드하며 만든 ‘webapi’

webapi DB의 public 스키마에 source 테이블 값은
1;ohdsi;ohdsi;jdbc:postgresql:localhost:5432/ohdsi?user={user}&password={password};postgresql

webapi DB의 public 스키마에 source_daimon 테이블 값은
1;1;0;webapi.public;0
2;1;1;webapi.public;1
3;1;2;webapi.public;0

입니다.

WebAPI/info 를 들어가면 version정보는 잘 나오는데
WebAPI/source/source 화면에서 에러가납니다.
에러내용은 아래와 같습니다.

혹시 해결방법을 아시는 분 계시면 도움을 요청드립니다.
감사합니다.


(Gregory Klebanov) #3

@kevin - The translation by Google Translate was good enough:) We will take a look at it and get back to you shortly

@Konstantin_Yaroshove, @pavgra


#4

source, source_daimon 설정이 정확하게 어떻게 되어있는지 파악이 필요할 것 같은데요.

source 테이블의 경우
SOURCE_NAME : ATLAS에 표시될 이름
SOURCE_KEY : CDM DB 이름
SOURCE_CONNECTION : JDBC 연결 정보 ex) jdbc:postgresql://{서버아이피}:{포트}/{CDM이름}?user={권한이 있는 Postgresql 유저 아이디}&password={권한이 있는 Postgresql 유저 비밀번호}
SOURCE_DIALECT : DB 종류 ex) postgresql
SOURCE_ID : 고유 번호

SOURCE_DAIMON 테이블의 경우 SOURCE 테이블에 SOURCE_ID키로 외래키가 걸려있기 때문에,
SOURCE_ID : 위 SOURCE 테이블의 SOURCE_ID와 맞춰서 입력
DAIMON_TYPE : 0,1,2,3,4,5 -> 0: CDM 스키마 이름, 1 :Voca 스키마 이름, 2. Result 스키마 이름, 5, temp 스키마 이름
TABLE_QUALIFIER : DAIMON_TYPE에 맞는 스키마를 넣어주시면 됩니다.
PRIORITY : ATLAS 상에 우선순위를 표시하기 때문에, 사용자가 ATLAS 에 접속했을 때 제일 먼저 참조하는 CDM 정보 입니다. 숫자가 높을 수록 우선순위가 높은 것으로 알고 있습니다.


(Donghun Kyeong) #6

모두 답변에 감사드립니다

위에서 source 부분에서 어떤 문제인지를 알아냈습니다…
WebAPI/source/sources 를 입력해야 했는데
그림에서 보시다시피 주소창의 마지막에 's’가 빠졌었네요…
주소를 잘못 입력하면 위와 같은 에러창이 나오는 것 같습니다.

여러 해결에도 Atlas에서 서버측 500 에러를 해결하지 못하여
평가판 Windows2016을 설치후 처음부터 설치과정을 다시 밟았습니다 ;;
다행히 이번에는 Atlas가 이전보다는 매끄럽게 돌아갑니다.

한가지 이전과 다른 점은, 서버측에서 jquery.js를 찾을 수 없다고 합니다.

해결 방법을 구합니다.

도움에 감사드립니다.


t