OHDSI Home | Forums | Wiki | Github

ATLAS Demo not loading

Hi there,

I was wondering if there is an issue with the Atlas Demo or if it’s just me? I have used it before and wanted to come back to it this week to practice creating cohorts on the demo datasets but it’s stuck on the loading screen. Is there anything I can do? Or is this something that is affecting others too?



Seems to be loading for me:

However, it was recently updated and you may be working from a cache…but we could check for errors: could you do ctrl-shift-I (hold control - shift - I) to open your console and check for errors, and also refresh browser while the console is open to see if any errors appear when you first load the page?


Hi there, thanks for replying. I didn’t know there was a console, and now I’ve opened it I have no idea what any of it means!

I’ve copied the first few lines of it here. Does this mean anything immediate to you?

Uncaught (in promise) ReferenceError: Unable to process binding “visible: function(){return toggleBrowserWarning(bowser) }”
Message: toggleBrowserWarning is not defined
at visible (eval at parseBindingsString (knockout-latest.js:68:398), :3:60)
at update (knockout-latest.js:104:137)
at a.B.i (knockout-latest.js:73:45)
at Function.Uc (knockout-latest.js:52:31)
at Function.Vc (knockout-latest.js:51:299)
at Function.U (knockout-latest.js:51:126)
at a.m.a.B (knockout-latest.js:49:150)
at knockout-latest.js:73:32
at Object.r (knockout-latest.js:11:297)
at m (knockout-latest.js:72:124)

Thanks so much for your help.


Yes, there’s a lot of information there for diagnostic purposes, so apologize for the complexity here, but it might help me understand what is happening.

The code for the toggleBrowserWarning function is found here. So if you open the console and then refresh the page, you should see under the Network tab a place to filter the network requests by a name. I filtered by appli in this screenshot, and you see that the javascript file Application.js was downloaded without error. So in my browser, it was able to start the page and find the function without error:

Can you check again by refreshing your browser and checking for this output, and see if the Application.js file downloads correctly? It could be some sort of firewall restriction in your environment or a browser restriction (a plugin or some restriction in your browser settings) that could be preventing the page from loading.

I think I’m checking this correctly - I’ve included a screenshot - but it looks like application.js is downloading.

EDIT: I’ve just tried clearing my browser cache and that has worked. Can’t believe it took me that long to think of such a simple thing. Thanks for your help!