OHDSI Home | Forums | Wiki | Github

Atlas Data Source Caching Issue


After configuring new data sources, some users are reporting that they are totally unable to view the new source. I have double checked that permissions exist for all applicable users to view the data source, but no matter what they do they cannot view the new source. We’ve narrowed it down to some sort of caching issue in the browser, but we are totally at a loss as how to resolve it. We’ve tried deleting the entire history, deleting all cookies, web data, everything, but nothing seems to stick. What’s even weirder is that if they log in on my machine, they’re able to see the data source.

We’re using OHDSIonAWS, with Atlas 2.7.5 and WebAPI 2.7.5. Is there someone that knows a way to clear whatever is cached so we can view the new datasets? If we can’t see the sets in the browser, or we have to jump through a lot of hoops every time a new source is configured, it kinda defeats the purpose of using this as an analysis platform.

I had some caching issues in the past and what worked was restarting the webapi tomcat, not sure if you have already tried that

I guess I could always try to do that. Thanks for the tip! I’ll reply if it seems to solve the issue.

@mnlubke did restarting webapi work for you? i truncated my old CDM tables, re-populated them with new patient records, deleted cookies, restarted webapi and ATLAS is still showing data from my old tables. The only difference is that am not using OHDIonAWS. I built ATLAS on an Ubuntu server.

Any help will be appreciated.


Did you find an answer to this issue?

Just saw your message @Sanjay_Udoshi . I solved it by reinstalling the CDM database.

1 Like

Resolved the same issue by running:

DELETE FROM webapi.achilles_cache