OHDSI Home | Forums | Wiki | Github

Atlas Concept Sets: Exported Set Different From Imported Set

Hi there,

I am an implementer who just finished setting up an instance of Atlas for internal use. One of our researchers pointed out to me that a concept set they obtained as a JSON file differed from the original exported set after importing it.

I am not a clinician and I don’t know right now if this constitutes expected behavior or a bug. To reproduce, I tried exporting a concept set from a public Atlas instance and re-importing it to that same instance. To my surprise they were not the same at all.

The exported set contained 72 concept set expressions and 253 included concepts. After exporting it as a JSON file (containing 72 CONCEPT_SET entries) and importing it into the same instance the new concept set had 95 entries in concept set expressions and 95 included concepts. I would include screen shots if this was possible.

The concept set in question is the following:

Thank you very much for your help.

I tried to reproduce it:

I went to the above cocnept set, exported the JSON, then closed the concept set, when to Search, and from there imported a new concept set. This is the result:

Could you confirm your steps to reproduce?

Hi Chris,

Thank you for the quick reply. I just figured out we’ve been doing it wrong. I greatly appreciate your help!