OHDSI Home | Forums | Wiki | Github

Ares Installation

How to install ares in local sever.

If you can use Docker at your site, then Broadsea 3.0 is an option. There is an ares profile to deploy the application. You’d need to run Achilles::exportToAres, DataQualityDashboard, and AresIndexer to build the files off of the CDM.

I started an Ares container, When U went to http://127.0.0.1/ares/#/home
got an error:

Is this expected?

Yes - if you haven’t run AresIndexer and loaded the files

Thank you very much for your help.

I am very new to this project and so, I need more guidance if possible.
Do I need to run:
exportToAres
DataQualityDashboard
ArexIndexer ?
How do I determine parameters in exportToAres : function (connectionDetails, cdmDatabaseSchema, resultsDatabaseSchema, vocabDatabaseSchema, outputPath,
reports = c())

The Broadsea env section for the data folder ARES_DATA_FOLDER="./ares_data" But where do I find the mount point for ARES?
And what DB credentials I need to use? Are postgres/mypass correct credentials to use for the default Broadsea project installation?

I had to install OHDSI/Achilles OHDSI/DataQualityDashboard and OHDSI/Dashboard packages in the R Studio even though the documentation sais that achilles is a part of HADES. What am I missing?

Is there any document that describes the whole process of getting Ares ready?

Again, thank you very much for your help.
Alla

@Frank - can you share the AresIndexer steps?

@neslonik - Once you run the AresIndexer steps, then in the env file, you simply set ARES_DATA_FOLDER to the output folder of those steps. The db credentials are going to be for your CDM.

Regarding HADES, those should be there; @lee_evans @admin have you seen those packages not appear in the Hades container?

Hello, I’m using Broadsea 3.1, and I had to install these packages myself as well.

2 Likes

I would be highly interested in the necessary AresIndexer steps as well.

So far I created a script based on the ones proposed in the doc and the gist. I guess they are outdated since the function Achilles::exportAO does not exist in the Achilles package.

However, the function Achilles::exportToAres exists. When using this function, in my case the step AresIndexer::buildNetworkIndex(sourceFolders = sourceFolders, outputFolder = aresDataRoot) fails with the messages:

! Can’t subset columns that don’t exist.

:heavy_multiplication_x: Column analysis_id doesn’t exist.

@felixw

Hi did you manage to install ARES ?

Thank you very much.

I got the same error as @felixw. That is, when running the AresIndexer::buildNetworkIndex() function, i got an error saying that Column analysis_id doesn’t exist. I was wondering if that is due to the upper/lower case for naming columns, ie, while calling AresIndexer::buildNetworkIndex(), it runs Achilles::getAnalysisDetails() internally, which generates a data.frame with columns “ANALYSIS_ID, DISTRIBUTION, DISTRIBUTED_FIELD”, all capitalized, but the AresIndexer::buildNetworkIndex() function (line 8) looks for columns “analysis_id”, “category”.

@Frank: Could you please help?

Hi @felixw , @linyingz ,

I had the same error and I was able to fix it by moving Achilles to its development branch version, as suggested here: Achilles analysis_id cannot be found · Issue #41 · OHDSI/AresIndexer (github.com).

Hope this helps!

Vittoria

I am still very interested in the necessary AresIndexer steps. Does anyone can share them?

t