OHDSI Home | Forums | Wiki | Github

Achilles_cache table, some report return result other not

Hello all,

I have a system running with PostgreSQL/Tomcat/Achilles/Atlas, few reports are returning data and others not. I ran every query for each report individually in the PostgreSQL and they all return values, I then tried to look for errors in the logs for webapi, tomcat and there was no errors, I checked the console and there is no error. Although when I was checking the tables and realized that the Achilles creates a achilles_cache table that will feed the reports in Atlas and this table has only few reports with data and most of then without data, I am new to this environment as it is a temporary work assignment. After reading the documentation I tried to use the Achilles Heel that could give me a possible indication about what is happening and I found out that I dont have it installed.
I could not find much about the achilles_table and I have been trying several approaches based on this forum, if someone out there could help me out to narrow the issue would be much appreciated.

Hello Raphael, in these database queries, you can generate reports by exporting them in “.CSV”, or “.TXT”, if you can, the problem is in the procedures for publishing these data!
Usually these temporary tables are used as support for the publication of query results.
Check the engine for publication!
Anything we can talk more about this subject!

Hello Henrique,
We made a copy of the alchilles_cache table, deleted the original and restarted the server(tomcat) and the problem was solved. I will be working with a new project soon, we surely will have a lot to talk if you are willing to help.

Raphael Nogueira

1 Like

Hello, could you elaborate more in how to create those .txt/.csv.
I am doing a new project and I deleted the achilles_cache, run the achilles function to populate the results once again, restarted the webapi, tomcat and no data in the achilles_cache.