OHDSI Home | Forums | Wiki | Github

WebAPI installation issue


(Ambuj) #21

Yes, i can get maven 3.5. I will try that and update you.
By any chance can you upload your pom.xml file here, i can refer the url’s mentioned to download.

(Chris Knoll) #22

I use the pom.xml directly out of the git repository, so I never modify it.

(Ambuj) #23

ok. I will try to degrade Maven from 3.6 to 3.5.3 and try it out. Were you also using CentOS?
Also, I am using Java 8, so shall I use Java 7 on it.

(Ambuj) #24

I tried changing the names in url in POM.xml from http://repo.odysseusinc.com/artifactory/community-libs-snapshot-local to http://repo.odysseusinc.com/artifactory/libs-release
and http://repo.odysseusinc.com/artifactory/community-libs-release-local to http://repo.odysseusinc.com/artifactory/libs-release
After that all the files gets downloaded without any issues.
When it started building .war file it started throwing WARNING messages and ended up with BUILD FAILURE.
I am uploading the errors for that.
Can you please confirm why change in the url made the downloading a success and later a failure in build due to connection time out error. Is this is an issue with the url ? because I do not have any firewall restrictions so far.
Sorry for eating your head on this but this is really concerning, I cannot decide whether its url issue or maven issue.


(Chris Knoll) #25

With the final error of ‘connection timed out’ it indicates failure to connect to the server. Network issues are annoying, but when I’m faced with this, I try to execute again and see if the network issue was temporary.

Also, I’m not sure the impact of changing the values in the pom.xml file. @pavgra or @gregk : can you please chime in on this, we seem to be having frequent issues with the Odysseus artifactory, and I have no visibility as to what might be wrong there.

(Ambuj) #26

@Chris_Knoll as suggested, I rolled back Maven 3.6.0 and installed 3.5.3 with fresh WebAPI retrieval from git.
however, the error is still there without any changes made to the urls.
Screenshot attached for your reference. looks like I am completely lost here now :frowning:

As soon as it started throwing error, I barred it to save time. Please help.

(Ambuj) #27

So here is what I did so far:
O.S Cent OS 7
Maven 3.5.3
Java 8
Scenario1 - No changes made to urls in POM.XML
When I tried to create the .war file, I got the errors for checksum validation for jackson-bom and log-bom files.
I tried to open those respective urls in browser
With both of them I get
“errors” : [ {
“status” : 404,
“message” : “File not found.”
} ]
Now, I manually tried to go through the path and I cannot find fasterxml mentioned within the url

So, is this an issue for which I am receiving errors?

Scenario2: Changes made in POM.XML
Following url’s has been changed


With this all the required files gets downloaded without any issues, but when the war file build comes in picture it shows the connection times out for sqlrender.

I am not getting which way to go through as I am getting errors with everything I am doing to make it work. @pavgra @gregk @anthonysena @Chris_Knoll

(Ambuj) #28

I am able to successfully build the .war file now. The issue was with the network only.

Thank you for your time and patience and apologies for eating up your time.

(Sarath Manikonda) #29

Were you able to deploy the war file and also verify it.
Couple of questions i had were:

  1. What version of PSQL are you using?
  2. Did the tables get created in OHDSI/Webapi schema?
  3. Were you able to add records to the Source and Source_Diamon tables and were you able to see the data using the url: ‘http://localhost:8080/WebAPI/source/sources

I am still struggling with .war file deployment.

(Ambuj) #30

yes, I was able to deploy war file after too many issues with the network here.

  1. What version of PSQL are you using? 10
  2. Did the tables get created in OHDSI/Webapi schema? yes, they creates as soon as you build and deploy the war file
  3. Were you able to add records to the Source and Source_Diamon tables and were you able to see the data using the url: ‘http://localhost:8080/WebAPI/source/sources’ - Yes, the records needs to be inserted manually to both the tables based upon the configuration and the schema you have. And once done, you will be able to view the entries of source and source_daimon using localhost:8080/WebAPI/source/sources.

(Sarath Manikonda) #31

Thanks a lot for sharing the information.
For me the tables are getting created in the WebAPI schema, but I see some issues in the logfile after the war file deployment. Not sure if they are having any impact.
But I am not able to access the ‘localhost:8080/WebAPI/source/sources’. May be i am missing something.
Could you please share the entries you made in the source and source_diamon tables. I am attaching the entries I made.

(Sarath Manikonda) #32

There were issues related to permission on the PostgreSQL DB. I fixed them and the WebAPI is deployed now. Thanks for your help.

(Ambuj) #33

Good to hear that :slight_smile: