OHDSI Home | Forums | Wiki | Github

Warning and tables not found in postgresql after deploying webAPI using Tomcat application


(Ramaswamy) #1

Hi i’m trying to install WebAPI and ATLAS for the first time.
When installing some WARNINGS appeared when i execute

C:\Git\OHDSI\WebAPI> mvn clean package -DskipTests -s WebAPIConfig/settings.xml -P {webapi-postgresql}

the following WARNINGS occurs
[INFO] Scanning for projects…
[WARNING]
[WARNING] Some problems were encountered while building the effective model for
org.ohdsi:WebAPI:war:2.8.0-SNAPSHOT
[WARNING] ‘dependencies.dependency.(groupId:artifactId:type:classifier)’ must be
unique: com.odysseusinc:data-source-manager:jar -> version 1.15.0-alpha vs ${ar
achne.version} @ line 720, column 17
[WARNING] ‘repositories.repository.id’ must not contain any of these characters
/:"<>|?* but found / @ line 364, column 11
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten t
he stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support buildin
g such malformed projects.
[WARNING]
[INFO]
[INFO] --------------------------< org.ohdsi:WebAPI >--------------------------
[INFO] Building WebAPI 2.8.0-SNAPSHOT
[INFO] --------------------------------[ war ]---------------------------------
[INFO]
[INFO] — maven-clean-plugin:2.5:clean (default-clean) @ WebAPI —
[INFO] Deleting C:\Git\OHDSI\WebAPI\target
[INFO]
[INFO] — maven-resources-plugin:2.6:resources (default-resources) @ WebAPI —

[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 2 resources
[INFO] Copying 1007 resources
[INFO] Copying 1 resource
[INFO] Copying 29 resources
[INFO]
[INFO] — maven-compiler-plugin:2.5.1:compile (default-compile) @ WebAPI —
[INFO] Compiling 798 source files to C:\Git\OHDSI\WebAPI\target\classes
[INFO]
[INFO] — maven-resources-plugin:2.6:testResources (default-testResources) @ We
bAPI —
[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 30 resources
[INFO]
[INFO] — maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ WebAP
I —
[INFO] Compiling 19 source files to C:\Git\OHDSI\WebAPI\target\test-classes
[INFO]
[INFO] — maven-surefire-plugin:2.18.1:test (default-test) @ WebAPI —
[INFO] Tests are skipped.
[INFO]
[INFO] — maven-failsafe-plugin:2.18.1:integration-test (default) @ WebAPI —
[INFO] Tests are skipped.
[INFO]
[INFO] — maven-war-plugin:2.2:war (default-war) @ WebAPI —
[INFO] Packaging webapp
[INFO] Assembling webapp [WebAPI] in [C:\Git\OHDSI\WebAPI\target\WebAPI]
[INFO] Processing war project
[INFO] Copying webapp resources [C:\Git\OHDSI\WebAPI\src\main\webapp]
[INFO] Webapp assembled in [14028 msecs]
[INFO] Building war: C:\Git\OHDSI\WebAPI\target\WebAPI.war
[INFO] Packaging classes
[INFO] Building jar: C:\Git\OHDSI\WebAPI\target\WebAPI-classes.jar
[INFO]
[INFO] — miredot-plugin:2.1.2:restdoc (default) @ WebAPI —
[WARNING] Rest Framework not explicitly set, using JAX-RS by default.

LATER NEGLECTED THE WARNING AND

STARTED THE TOMCAT AND RUNNED “IN COMMAND PROMPT”
C:\tomcat\bin> catalina.bat run > …\logs\webapi.log 2>&1


DEPLOYED  webAPI.war file in TOMCAT/MANAGER
 and checked in the webapi.log file and found this message in the last line which is mentioned below..

INFO [http-nio-8080-exec-9] org.apache.catalina.startup.HostConfig.deployWAR Deployment of web application archive [C:\tomcat\webapps\WebAPI.war] has finished in [45,664] ms

I HAVE NOT FIND THE LINE WHICH IS MENTIOND IN THE WEBAPI INSTALLATION GUIDE..
org.ohdsi.webapi.WebApi - - Started WebApi in xx.xxx seconds (JVM running for yy.yy)

currently I’m using
windows 7
jdk 1.8.0_221
apache maven : 3.6.1
apache tomcat : 8.5.43
postgresql 9.6 and also 10.9 in another system

would much appreciate your help!

(Chris Knoll) #2

There are some warnings that you can ignore, but this one was strange:

[WARNING] ‘repositories.repository.id’ must not contain any of these characters
/:"<>|?* but found / @ line 364, column 11

I checked the pom.xml file in the master branch, and this is what is onl ine 363-365:

   <repository>
      <id>ohdsi</id>
      <name>repo.ohdsi.org</name>

There are no invalid characters there. So, can you check your pom.xml file line 364 and tell me what you have in there?

I’m not sure why you aren’t seeing the webAPI logging in the log file, it is possible that it’s output to a different log in the tomcat path (maybe in catalina home). But, to see i the service is actually responding, you can access {server}:8080/WebAPI/info and you should get a response with the current version.


(Ramaswamy) #3

Thanks Chris,

The warning is due to the modification done by me in pom.xml file, as it was not generating the war file…

now i have copied the pom.xml file from the master branch and executed it…

I got a warning ie: [WARNING] Rest Framework not explicitly set, using JAX-RS by default
and WebAPI.war is created in the target WebAPI subfolder.

C:\Git\OHDSI\WebAPI> mvn clean package -DskipTests -s WebAPIConfig/settings.xml
-P {webapi-postgresql}
[INFO] Scanning for projects…
[INFO]
[INFO] --------------------------< org.ohdsi:WebAPI >--------------------------
[INFO] Building WebAPI 2.8.0-SNAPSHOT
[INFO] --------------------------------[ war ]---------------------------------
[INFO]
[INFO] — maven-clean-plugin:2.5:clean (default-clean) @ WebAPI —
[INFO]
[INFO] — maven-resources-plugin:2.6:resources (default-resources) @ WebAPI —

[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 2 resources
[INFO] Copying 1010 resources
[INFO] Copying 1 resource
[INFO] Copying 29 resources
[INFO]
[INFO] — maven-compiler-plugin:2.5.1:compile (default-compile) @ WebAPI —
[INFO] Compiling 816 source files to C:\Git\OHDSI\WebAPI\target\classes
[INFO]
[INFO] — maven-resources-plugin:2.6:testResources (default-testResources) @ We
bAPI —
[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 30 resources
[INFO]
[INFO] — maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ WebAP
I —
[INFO] Compiling 19 source files to C:\Git\OHDSI\WebAPI\target\test-classes
[INFO]
[INFO] — maven-surefire-plugin:2.18.1:test (default-test) @ WebAPI —
[INFO] Tests are skipped.
[INFO]
[INFO] — maven-failsafe-plugin:2.18.1:integration-test (default) @ WebAPI —
[INFO] Tests are skipped.
[INFO]
[INFO] — maven-war-plugin:2.2:war (default-war) @ WebAPI —
[INFO] Packaging webapp
[INFO] Assembling webapp [WebAPI] in [C:\Git\OHDSI\WebAPI\target\WebAPI]
[INFO] Processing war project
[INFO] Copying webapp resources [C:\Git\OHDSI\WebAPI\src\main\webapp]
[INFO] Webapp assembled in [15797 msecs]
[INFO] Building war: C:\Git\OHDSI\WebAPI\target\WebAPI.war
[INFO] Packaging classes
[INFO] Building jar: C:\Git\OHDSI\WebAPI\target\WebAPI-classes.jar
[INFO]
[INFO] — miredot-plugin:2.1.2:restdoc (default) @ WebAPI —
[WARNING] Rest Framework not explicitly set, using JAX-RS by default.

but i did not get the message as " [INFO] BUILD SUCCESS " in the command prompt
should i ignore the warning and continue…?
if yes,
then I have ignored the warning and continued to deploy the webAPI.war in tomcat manager
i got the information in webapi log file… the last line in that file is mentioned below
INFO [http-nio-8080-exec-9] org.apache.catalina.startup.HostConfig.deployWAR Deployment of web application archive [C:\tomcat\webapps\WebAPI.war] has finished in [46,613] ms

hence, I verified the the database,i did not find tables in the schema webapi ie: tables were not created/generated in the database"OHDSI of schema"webapi" .(Database platform is PostgreSQL 9 AND 10)

i have accessed localhost:8080/WebAPI/info to check whether WebAPI is working & i did not get the version as output

i am unable to upload the webAPI log file as i am a new user

Any suggestions to create the war file that I can successfully deploy? Thank you


(Anthony Sena) #4

@Ram - it looks like the problem may be related to the maven command:

C:\Git\OHDSI\WebAPI> mvn clean package -DskipTests -s WebAPIConfig/settings.xml -P {webapi-postgresql}

Can you remove the {} from the webapi-postgresql part of the command and try re-deploying the war?


(Ramaswamy) #5

Thanks @anthonysena

I remove the {} from the webapi-postgresql part of the command and try to deploy the war and i got the same warning…

C:\Git\OHDSI\WebAPI> mvn clean package -DskipTests -s WebAPIConfig/settings.xml
-P webapi-postgresql
[INFO] Scanning for projects…
[INFO]
[INFO] --------------------------< org.ohdsi:WebAPI >--------------------------
[INFO] Building WebAPI 2.8.0-SNAPSHOT
[INFO] --------------------------------[ war ]---------------------------------
[INFO]
[INFO] — maven-clean-plugin:2.5:clean (default-clean) @ WebAPI —
[INFO] Deleting C:\Git\OHDSI\WebAPI\target
[INFO]
[INFO] — maven-resources-plugin:2.6:resources (default-resources) @ WebAPI —

[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 2 resources
[INFO] Copying 1010 resources
[INFO] Copying 1 resource
[INFO] Copying 29 resources
[INFO]
[INFO] — maven-compiler-plugin:2.5.1:compile (default-compile) @ WebAPI —
[INFO] Compiling 816 source files to C:\Git\OHDSI\WebAPI\target\classes
[INFO]
[INFO] — maven-resources-plugin:2.6:testResources (default-testResources) @ We
bAPI —
[INFO] Using ‘UTF-8’ encoding to copy filtered resources.
[INFO] Copying 30 resources
[INFO]
[INFO] — maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ WebAP
I —
[INFO] Compiling 19 source files to C:\Git\OHDSI\WebAPI\target\test-classes
[INFO]
[INFO] — maven-surefire-plugin:2.18.1:test (default-test) @ WebAPI —
[INFO] Tests are skipped.
[INFO]
[INFO] — maven-failsafe-plugin:2.18.1:integration-test (default) @ WebAPI —
[INFO] Tests are skipped.
[INFO]
[INFO] — maven-war-plugin:2.2:war (default-war) @ WebAPI —
[INFO] Packaging webapp
[INFO] Assembling webapp [WebAPI] in [C:\Git\OHDSI\WebAPI\target\WebAPI]
[INFO] Processing war project
[INFO] Copying webapp resources [C:\Git\OHDSI\WebAPI\src\main\webapp]
[INFO] Webapp assembled in [15217 msecs]
[INFO] Building war: C:\Git\OHDSI\WebAPI\target\WebAPI.war
[INFO] Packaging classes
[INFO] Building jar: C:\Git\OHDSI\WebAPI\target\WebAPI-classes.jar
[INFO]
[INFO] — miredot-plugin:2.1.2:restdoc (default) @ WebAPI —
[WARNING] Rest Framework not explicitly set, using JAX-RS by default.

though i ignored the warning and deployed it in tomcat, yet it did not create/generate tables in the database"ohdsi" of schema"webapi"


(Josef Hardi) #6

@Ram - could you please verify your .war deployment?

Go to http://localhost:8080/manager and see if /WebAPI is on the list. If you can see it, check if you can run the service by clicking the “Start” button.

If you can’t run it then you might have misconfigured the “ohdsi” database in PostgreSQL. Please revisit the instructions again (–> https://github.com/OHDSI/WebAPI/wiki/PostgreSQL-Installation-Guide) and make sure you do everything correctly. I have a feeling you miss the granting permission for the “ohdsi_admin_user” to create tables in the database.

Hope this helps!


(Ramaswamy) #7

Thanks @anthonysena

deployed the war file successfully.


(Ramaswamy) #8

Thanks @johardi
made some changes in the pom file and executed… hence
successfully deployed the war file…


t