OHDSI Home | Forums | Wiki | Github

Postgres 13

Hi, I am working on a new installation of ohdsi and am having trouble getting webapi and the database connected. I have tried both broadsea and a traditional tomcat webapi install and config. With broadsea, I could get the initial flyaway connection to work and build the schema, but ran into issues connecting via the browser (“application installation failed. Unable to connect to an instance of webapi…”). Troubleshooting the normal issues that cause that message did not lead to a resolution, so I went ahead with the manual tomcat install. This is failing on startup of the tomcat process with a permission denied connection failure for the postgres jdbc connection. The connection works fine with a manual psql using that user/password from the box, and there doesn’t appear to be a firewall issue either. I have tried a newer jdbc connector also.
I am about to punt on webapi for a while and concentrate on the omop cdm load, but I wanted to check and make sure postgres 13 (on RHEL linux) is a valid compatible version. I have seen a lot of references to postgres 10 and one comment on postgres 12, but wanted to make sure.

We’re on PG 12.3 RHEL, no issues