OHDSI Home | Forums | Wiki | Github

Getting CPT concepts in my CONCEPTS table


(Romir Moza) #1

I am trying to run the “java -jar cpt4.jar 5” with my newly created umls account and get the following error:

[ERROR] 2020-02-13 18:16:50.438 [main] Application - Cannot process CONCEPT.csv file. You can find more details in the logs/logfile.log file.

Reason: Wrong user/password combination or not enough permissions on your account to execute Java. Please check your privileges.

logfile:

[ERROR] 2020-02-13 18:26:53.613 [main] ApplicationContextServer - Cannot initialize application
gov.nih.nlm.uts.webservice.UtsFault_Exception: Error getting a ticket granting ticket: null
at jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:?]
at jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:?]
at jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:?]
at java.lang.reflect.Constructor.newInstanceWithCaller(Constructor.java:500) ~[?:?]
at java.lang.reflect.Constructor.newInstance(Constructor.java:481) ~[?:?]
at com.sun.xml.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:117) ~[cpt4.jar:?]
at com.sun.xml.ws.client.sei.StubHandler.readResponse(StubHandler.java:223) ~[cpt4.jar:?]
at com.sun.xml.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:176) ~[cpt4.jar:?]
at com.sun.xml.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:263) ~[cpt4.jar:?]
at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:89) ~[cpt4.jar:?]
at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:62) ~[cpt4.jar:?]
at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:131) ~[cpt4.jar:?]
at com.sun.proxy.$Proxy54.getProxyGrantTicket(Unknown Source) ~[?:?]
at org.odhsi.utils.cpt.ApplicationContextServer.init(ApplicationContextServer.java:44) [cpt4.jar:?]
at org.odhsi.utils.cpt.Application.main(Application.java:44) [cpt4.jar:?]

I have tried running the script as a super user and double-checked user/password and they are correct.

Any ideas as to what might be wrong?


(Yaroslav) #2

Hi @Romir_Moza.
Most likely your umls username/password contains special characters. Try quoting them:
java -Dumls-user=“username” -Dumls-password=“password” -jar cpt4.jar 5


(Romir Moza) #3

Hi @Yaroslav,

Thanks for replying. I tried quoting the username/password, but the error persists.


(Roger Carlson) #4

Do you have a current EULA?


(Christian Reich) #5

What’s not current about it?


(Roger Carlson) #6

My understanding is that the EULA for CPT4 codes can expire. I’m just asking
@Romir_Moza if they’re certain it is current.


(Anna Karenina) #7

The similar error has been reported before. Just in case: which version of Java are you using?


t