OHDSI Home | Forums | Wiki | Github

Error in installing R-Packages


(Taha Abdul-Basser) #21

Thanks for letting us know. This will help other Mac users! :slight_smile:


(Giorgio Oliviero) #22

Hi, I get similar error, while I was installed ggplot2, after an update of it;
could you please help me?
thanks in advance

library(“ggplot2”)

Error in dyn.load(file, DLLpath = DLLpath, …) :

unable to load shared object ‘/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rlang/libs/rlang.so’:

dlopen(/Library/Frameworks/R.framework/Versions/3.2/Resources/library/rlang/libs/rlang.so, 6): Library not loaded: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libR.dylib

Referenced from: /Library/Frameworks/R.framework/Versions/3.2/Resources/library/rlang/libs/rlang.so

Reason: Incompatible library version: rlang.so requires version 3.5.0 or later, but libR.dylib provides version 3.2.0

In addition: Warning message:

package ‘ggplot2’ was built under R version 3.5.2

Error: package or namespace load failed for ‘ggplot2’


(mintmountain89) #23

Hi,

It looks like you installed a new version of R (3.5) on top of a previous version (3.2).

reference: https://community.rstudio.com/t/every-libraries-failed-to-load-after-upgrading-r-to-3-6-0/29736/21

If you’ve recently updated your R version, it will look for your installed libraries in a new directory, e.g., R/x86_pc_linux-gnu-library/3.6 (where previously you used, e.g., R version 3.4). On Windows platforms, there is a hand function to move all your installed libraries over to the new directory. For MacOS and Linux platforms, many libraries need to be compiled from source.

reference: https://community.rstudio.com/t/problem-loading-tidyverse-incompatible-library-version-readxl-so-requires-version-3-5-0-or-later-but-libr-dylib-provides-version-3-4-0/29703

Try updating your packages with
update.packages(repos='http://cran.rstudio.com/', ask=FALSE, checkBuilt=TRUE)


(Giorgio Oliviero) #24

Thanks very much for your amazing quick replay;
very useful;
I’ve checked my current version which is 3.2;
unfortunately from this directory : Library/frameworks/R.frameworks/versions/
I could see only 2 folder , label 3.2 and current;

Do you have any Idea I could uninstall the 3.5 , which actually “shadow” the 3.2

thanks again


(mintmountain89) #25

Afraid I don’t know how to uninstall the 3.5, have you tried to update the R packages under 3.5?

update.packages(repos=‘http://cran.rstudio.com/’, ask=FALSE, checkBuilt=TRUE)


(mintmountain89) #26

you can also change the version of R that RStudio uses back to 3.2


t