OHDSI Home | Forums | Wiki | Github

CohortMethod run outof time

I run the CohortMethod package to create propensity score matching plots. The first time it was successful, but the second time I used the same code the createPs function never finishing running. If I interrupt the running, will get this error alert

  1. How could I troubleshoot this problem?
  2. Could we ATALS WebAPI to display the propensity score matching/Kaplan-Meier plot?

Depending on the size of the population, number of covariates, and especially the number of cores you assign, fitting a propensity can take a really long time (worst case: > 100,000 persons, > 100,000 covariates, 1 core will take weeks)

You can modify the behavior of Cyclops using the control argument of the createPs function. A first step would be to set the number of threads to however CPU cores you have available. I also recommend setting noiseLevel = "quiet" to get more information while it is running. See the Cyclops documentation for details.

1 Like

Thank you Dr.Schuemie!

I successfully run the code and saw the result last week. It took me 48 minutes to run this single study.
Today I run the same code again and got this error.

Another problem I have is: I used ATLAS Estimation generated the package"Estimation1118", and tried to load it in R Studio to see the results in shiny app. I followed the readme.md steps. All the dependencies in readme.md in step 1 are attached but cannot run step 2. Are there any steps I missed?

The first error message suggests you’ve updated Cyclops to a newer version incompatible with the other packages. Note that ATLAS is behind the R packages, so you really must not update anything, to keep the code generated by ATLAS happy.

I’m not sure about the second error. R says it can’t find the manual pages and other documentation objects. Could you try clicking “Install and Restart” in R studio instead of calling install()?

1 Like

Thank you for your answer!
It seems I encounter the same package version problem when running another study. (My ATLAS webapi version is 2.7.7.)
Is there any method/documentation to check which version of the packages should I run for different studies?

Luckily that is one of the newer studies, where we’ve started using renv to manage the installation of the required package versions. I just can’t seem to find the instructions for running Charybdis with renv. @anthonysena: am I missing someting?

Hi Dr. Schuemie,
I’m trying to run Population-Level Estimation studies designed on our ATLAS WebAPI
I encountered errors when executing the study. The screenshots are from two packages I’ve run, there are some unexpected “n” in the code


detailed error report: OHDSI_packages/Estimation_Study_error at main · ChenyuL/OHDSI_packages · GitHub

Is it something wrong with the study design? How can I troubles this problem?

Thank you!

The error you are seeing is unrelated to the ‘n’ characters you notice (those seem to be some weird artifact of printing the output).

I just posted information on this error and how to solve it.

Hi Dr. @schuemie, When I run an ATLAS generated PLE package, I got this error after updating some dependency packages. But not sure if it’s because of my study design or the dependencies.

Where could I find the dependencies version for study packages generated by ATLAS 2.7.7?

Thank you!