OHDSI Home | Forums | Wiki | Github

Can't bulid WebAPI .war

C:\Git\OHDSI\WebAPI> mvn clean package -DskipTests -s WebAPIConfig/settings.xml -P webapi-postgresql


build WebAPI.war failure

really need help ? Does anyone can teach me how to solve it .

Try removing the space after the -P so it is


Also, if you could just do mvn -v and report which version of maven you are using.

I try use the “-Pwebapi-postgresql” but still useless.
my maven version is 3.8.1

Ok, the solution to using maven 3.8.1 is found here:

thank you Chris ! But I still can’t solve the problem according to your method. some new ERROR happend. I think there is something wrong with the MAVEN installation. Please help me solve the problem.

If it is still a question I used something like this on Windows:
the test skipping switch was different, and it worked with 2.9.1 version
mvn clean package -Dmaven.test.skip=true -s WebAPIConfig/settings.xml -P webapi-postgresql

and check the Java version and environment variables (use the exact version (with latest subversion) which is refferred on git wiki)