OHDSI Home | Forums | Wiki | Github

Atlas LDAP import groups

atlas

#1

Hi,

today I was able to set the LDAP authentication service for Atlas.
First things first - Helping others to implement it aswell:

For everyone who is struggling with the configuration, maybe this will help you:

These are the configurations one has to set within the settings.xml according to the documentation:

<security.ldap.dn>CN={0},OU=people,DC=example,DC=com</security.ldap.dn>
<security.ldap.url>ldap://192.168.58.102:389</security.ldap.url>
<security.ldap.baseDn>OU=people,DC=example,DC=com</security.ldap.baseDn>
<security.ldap.system.username>admin</security.ldap.system.username>
<security.ldap.system.password>adminPW</security.ldap.system.password>

Additionally the searchBase got to be set. F.e:

<security.ldap.searchBase>OU=people,DC=example, DC=com</security.ldap.searchBase>

For my instance, it was set to a wrong search Base so I had to set it again. After that I could just login the normal way.

But lets come to my question:

When I try to import Users within the configuration section, I have to set a group to the choesen role.
When I am about to click on a role, Atlas wants me to search for group within my LDAP structure I guess.

For this, I just created a new “groupOfNames” in my openLDAP (f.e. called “Testgroup”), related some users to this group and tried to search for it. The problem here is, that Atlas cant find anything. After hitting the “next” button, it cant find users aswell.

I am able to log in with the users of my LDAP, but I dont want to set the roles to every single user, since there are a lot of users with a lot of different OUs. In this context, I would maybe switch from the OUs to groups, so that more than one OU can participate on the Atlas instance, since I cant set multiple OUs in my settings.xml file.

Did someone test this feature and could tell me for what Atlas is looking? I already tried the “groupOfUniqueNames” but it brings the same result. No imported users and no role to group relation.

Thank you in advance


t