OHDSI Home | Forums | Wiki | Github

Achilles hangs and does not finish execution

Hi everyone,

I’m trying to run Achilles on my cdm but I have an issue.

When I run Achilles the output it returns on terminal states that it has completed 99% of the queries but having reached this point it hangs and gives no more output until the process is killed manually. In the log file (log_achilles.txt) all the query completion logs are returned until query 2201 is completed and then it gives no more output in the file.

Thanks in advance to anyone who can help me.


Can you tell me what version of Achilles you are running along with the specifications of your server environment and database platform?


  • Achilles v1.7.2
  • db: postgresql 10.12
  • server environment:
    - os: red hat 8
    - ram 8GB
    - Intel Xeon Gold 6140 CPU @2.30GHz

We use two VMs, one for app and one for the db.

Either a particular analysis is hanging or the final step which merges all of the results is hanging. You can attempt to run Achilles::achilles with a parameter, analysisIds = c(1,2), to run just two analyses and ensure its not a broader problem. If this completes then its either a hanging analysis or the final merge. Reviewing the log might give you insights on which analysis is causing the hang.

Thank you for your help and suggestions.

Following your advice, I attempted to run only two or three analyses, and I successfully completed the process.

When examining the log file generated by Achilles after attempting to run the full set of analyses, it appears that all the analyses have been completed. However, I am unable to gather any insights regarding the merging process, as the last lines in the log files pertain only to the most recent analysis performed.

I am attaching the log file in case you want/could look at it:
log_achilles.txt (216.0 KB)

Thanks again for the help you are giving me


We tried to run again the analyses and we saw in the db logs the following error:
relation "results.achilles_results_dist" does not exists.

We tried to create the achilles_results_dist manually and run again the analyses but we ran into another error:
relation "results.achilles_heels_results" does not exists.

Shouldn’t these tables be created automatically by running the achilles function?

Thanks again for your help,